Cisco CCNA Switching | EtherChannel

  • By Sumaiyya Bagwan
  • June 11, 2019
  • CiscoNetworking
Cisco CCNA Switching | EtherChannel

[et_pb_section fb_built=”1″ admin_label=”section” _builder_version=”3.22.3″][et_pb_row admin_label=”row” _builder_version=”3.22.3″ background_size=”initial” background_position=”top_left” background_repeat=”repeat”][et_pb_column type=”4_4″ _builder_version=”3.0.47″][et_pb_text admin_label=”Text” _builder_version=”3.0.74″ background_size=”initial” background_position=”top_left” background_repeat=”repeat”]

Let’s Learn About The Etherchannel | CCNA Switching And Routing Training In Pune

In this blog series I am going to illustrate switching technology titled EtherChannel. The EtherChannel is a port link accretion technology or port-channel structural design used primarily on Cisco switches. EtherChannel allows assemblage of a number of real Ethernet links. By assembling them, it establishes a logical Ethernet link for the assurance of providing fault-tolerance and high-speed links. EtherChannel can be establish between switches, routers and the servers. This is important technology in CCNA switching that is taught in the CCNA training classes like Seven Mentor in Pune.

  • Link Aggregation

1 link aggregation

Spanning Tree Protocol blocks port Fa0/2 link to prevent loops.

2 STP

Switching EtherChannel allows STP to consider the physical links as one logical port that enables multiple ports to operate in Forwarding mode simultaneously.

  • High Speed

3 High Speed

Switching EtherChannel using 3 Physical Interfaces of Fast Ethernet Links of 100Mbps

4 pic

One 300Mbps switching EtherChannel Port Link Po1

A maximum of 8 Fast Ethernet or 8 Giga Ethernet ports can be assembled together when forming an EtherChannel.

There are 3 mechanisms you can choose to configure EtherChannel:

  • Port Aggregation Protocol (PAgP)
  • Link Aggregation Control Protocol (LACP)
  • Static (On)

 

For Free Demo classes Call: 7798058777

Registration Link: Click Here!

 

  • PAgP (Port Aggregation Protocol): This is Cisco Proprietary Protocol. PAgP working modes are as below –
    • Auto: Act in response to PAgP messages, but does not aggressively negotiate a PAgP EtherChannel. A channel is formed only if the port on the other end is primed to Desirable. This is the default working mode.
    • Desirable: Port vigorously negotiates channelling status with the interface on the other end of link. A channel is established if the other side is Auto or Desirable.
    • ON: In this genre, the interface will be a part of EtherChannel but no negotiation takes place.
    • Off: No EtherChannel constituted on the interface.

PAgP

Desirable Auto
Desirable Yes Yes
Auto Yes No
  • Configuration: Now let’s get working out for how to configure CCNA switching EtherChannel using PAgP.

5 pic

S2(config)# interface range fa0/1-3
S2(config-if)# channel-group 1 mode desirable
S2(config-if)# exit
S2(config)# interface port-channel 1
S2(config-if)# switchport trunk encapsulation dot1q
S2(config-if)# switchport mode trunk
S3(config)# interface fa0/1-3
S3(config-if)# channel-group 1 mode    auto
S3(config-if)# exit
S3(config)# interface port-channel 1
S3(config-if)# switchport trunk encapsulation dot1q
S3(config-if)# switchport mode trunk
  • LACP (Link Aggregation Control Protocol): This is IEEE protocol with Standard 3ad. LACP working modes are as below –
    • Passive: Act in response to LACP messages but does not aggressively negotiate a LACP EtherChannel. A channel is established only if the other end is set to Active.
    • Active: Port vigorously negotiates channelling with the interface on the other end of the link. A channel is established if the other side is passive or active.
    • ON: In this genre, the interface will be a part of EtherChannel but no negotiation takes place.
    • Off: No EtherChannel constituted on the interface.
LACP Active Passive
Active Yes Yes
Passive Yes No

 

  • Configuration: Now let’s get working out for how to configure CCNA switching EtherChannel using LACP

6 pic

S2(config)# interface range fa0/1-3
S2(config-if)# channel-group 1 mode active
S2(config-if)# exit
S2(config)# interface port-channel 1
S2(config-if)# switchport trunk encapsulation dot1q
S2(config-if)# switchport mode trunk
S3(config)# interface fa0/1-3
S3(config-if)# channel-group 1 mode    passive
S3(config-if)# exit
S3(config)# interface port-channel 1
S3(config-if)# switchport trunk encapsulation dot1q
S3(config-if)# switchport mode trunk
  • Static(On): Precise settings that must be identical includes –
    • Speed settings
    • Duplex mode, STP
    • VLAN membership (For Access Ports)
    • Native VLAN (For Trunk Ports)
    • Allowed VLANs (For Trunk Ports)
    • Trunking Encapsulation (ISL or 802.1Q)
  • Commands to Troubleshoot Switching EtherChannel:

Switch # show etherchannel

Switch # show etherchannel port-channel

Switch # show etherchannel summary

 

  • Important Notes:
    • Switching EtherChannel will not form if either Dynamic switched VLANs or Switch Port Security are enabled on the contributing EtherChannel switching interfaces.
    • Do not try to practise more than 48 EtherChannels on the switch or switch stack.
    • Set up a PAgP EtherChannel with up to eight Ethernet ports of the same type.
    • Set up a LACP EtherChannel with up to 16 Ethernet ports of the same type. Possible eight ports can be active, and up to eight ports can be in standby mode.
Set up all ports in an EtherChannel to operate at the same speeds and duplex

For Free Demo classes Call: 7798058777

Registration Link: Click Here!

Call the Trainer and Book your free demo Class for now!!!

call icon

© Copyright 2019 | Sevenmentor Pvt Ltd.

[/et_pb_text][/et_pb_column][/et_pb_row][/et_pb_section]

18 thoughts on “Cisco CCNA Switching | EtherChannel

  1. Wow… Really helpful blog Sumaiyya Mam. Waiting for more such blogs from you.

  2. Suhail Dilawar Bagwan Reply

    Good knowledge by writer
    Thnkx for the information & keep it up

  3. Vittal Rajaram Patil Reply

    It’s really nice mam and any buddy can understand easily… Thanks 4 valuable info please update such information regularly basis so it will help us.

    Thanks a lot….!

  4. It’s really nice mam….. Very useful and any one can understand easily.

  5. Good work mam ,easy to understand whatever written in this blog.

  6. Very interesting blog mam.. Specially the way you have explained everything along woth configurations

  7. Really appreciate your work. It looks like you have taken lots of afford for this blog, That is the reason it is very easy to understand 🙂

  8. It’ really nice mam…Thanks for the information

    Thanks a lot mam

  9. It’s really nice mam…Thanks for the information..

    Thanks a lot mam

  10. Really helpful blog..!

  11. How easily you have cleared the concept “EtherChannel”,
    Anyone can understand and configure by reading once.

    Thank you for adding knowledge bits, Awaiting to read more from you.

  12. Extremely informative article, understanding the usage of link aggregation and EtherChanneling is really great idea if the network have need of large bandwidth most of the times.. Great work, expecting more similar articles.

    GPON and EPON are new concepts that needs to be introduced, i would like to read an article on it from you mam!

    Beat wishes..

  13. It’s really nice and helpful information mam. Easy to understand also….?

  14. Very helpful article?

  15. My brother suggested I might like this web site. He
    was entirely right. This post truly made my
    day. You cann’t imagine simply how much time I had spent for
    this info! Thanks!

  16. Hello! Quick question that’s entirely off topic. Do you know how to make your site
    mobile friendly? My weblog looks weird when viewing from my iphone.
    I’m trying to find a theme or plugin that might be able
    to correct this problem. If you have any recommendations, please share.
    Thank you!

Submit Comment

Your email address will not be published. Required fields are marked *

*
*